Forum

SOLVED - error 98 &...
 
Notifications
Clear all

SOLVED - error 98 & power shutdown

2 Posts
2 Users
2 Likes
1,100 Views
James
Posts: 12
Topic starter
(@james12169)
Eminent Member
Joined: 5 years ago

I have a TC with two batteries.

One developed several faults outside of warranty. 1 When connecting the charger the red light would turn to green after only 20 second and I would have to repeatedly unplug and plug in the charger until the red light stayed on and the battery began charging correctly. 2 Error 98 would flash up and then the Soco would power off. After waiting a few minutes I was able to restart, but the same thing would happen a little later. Using the 1 power setting instead of 2 or 3 helped a little, but the shut down would still happen eventually.

I could not find anyone to service the battery and decided to open it up and check for any obvious faults before scrapping it and spending over £1'000 for a new one. I am no expert at this!

I removed the screws in the top cover and gently lifted it out with the connector wires still attached and this allowed me to unscrew and slide off the metal case surrounding the battery. I checked for any loose or burned wires or connectors - but all seemed good. 

Before giving up I disconnected the only connector block at the top which has quite a few wires leading into it and is thin and wide. I had learned that disconnecting this "re sets" the Battery Management System (BMS). I left it disconnected for half an hour in case there was any residual memory before reconnecting and refitting the battery on my Soco.

I tested the bike rigorously on all power settings and full throttle uphill for hours on end. The bike apears to be functioning perfectly with no error messages and no power shutdowns.

I've seen quite a few similar problems posted on this forum, so I hope this will help other Soco riders, James.

1 Reply
Posts: 177
(@flyingelectric)
Estimable Member
Joined: 5 years ago

I had a similar problem once after I let the battery sit for a month without use some years ago with my original Super Soco TS battery.

What I did was that I took of the battery of the bike and charged it directly but it didn't work so I tried again and maybe something reset and it started to charge.

Reply