Forum

Battery Charging Fa...
 
Share:
Notifications
Clear all

Battery Charging Fault & Mystery Fix!


James
Posts: 11
Topic starter
(@james12169)
Active Member
Joined: 3 years ago

Here's an odd one for you guys -

Battery was at 25% and I connected the charger, but the red light turned to green after 20 seconds. I repeated this quite a few times with same result each time. For no justifiable reason I connected the charger each time I passed and each time the red light turned green after 20 seconds. I continued to do this over four days charging for 20 seconds approximately 30 or 40 times. Suddenly today the charger continued charging instead of cutting out as usual - and it has now been charging for about 4 hours ........ so all seems well again.

This might help anyone who encounters the same problem ........ alternatively, if you can explain what was going on, I would really like to know.

James.

Topic Tags
6 Replies
ThomasIAm
Posts: 12
(@thomasiam)
Active Member
Joined: 8 months ago

Was it cold out or was the battery not completely dry? These factors could have triggered some kind of protection in the charger.

Reply
James
Posts: 11
Topic starter
(@james12169)
Active Member
Joined: 3 years ago

No, not cold at all and perfectly dry. Any ideas?

Reply
RZEE
Posts: 27
 RZEE
(@rzee)
Eminent Member
Joined: 11 months ago

What enviromental temparature you charging ? 

Reply
1 Reply
James
(@james12169)
Joined: 3 years ago

Active Member
Posts: 11

@rzee Room temperature - 60 degrees Fahrenheit and no moisture or high humidity. It's weird ....

Reply
RZEE
Posts: 27
 RZEE
(@rzee)
Eminent Member
Joined: 11 months ago
Posted by: @james12169

Room temperature - 60 degrees Fahrenheit and no moisture or high humidity. It's weird ....

That should be ok, many do not realize this battery's won't charge below zero degree celcius. 

Reply
1 Reply
James
(@james12169)
Joined: 3 years ago

Active Member
Posts: 11

@rzee

I for one did not know that.

But it was well above freezing in this case.

For the record, battery and charger are both functioning normally.

Like I said, very weird!

Reply
Share: